System Requirements


This product is optimized to operate with Microsoft Internet Explorer 7.0 or higher, and Firefox 3.0 or higher.


For best performance, Adobe Reader 8 is recommended in order to view PDFs.